summaryrefslogtreecommitdiffhomepage
path: root/tracker-pt/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2018-01-18 09:40:23 +0100
committerStanislaw Halik <sthalik@misaki.pl>2018-01-18 09:40:46 +0100
commita7a60c8f5328d8d1b6dbb2d73635ab64aa480d41 (patch)
tree2394df68f8cb40825ef6afcb89afbc81ec88f4f8 /tracker-pt/CMakeLists.txt
parent0d32aec11d09f1ac1088b05a214432b6be4b534b (diff)
tracker/pt: split impl and algorithm
Issue: #718
Diffstat (limited to 'tracker-pt/CMakeLists.txt')
-rw-r--r--tracker-pt/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tracker-pt/CMakeLists.txt b/tracker-pt/CMakeLists.txt
index aa4c89f6..a02bdfe0 100644
--- a/tracker-pt/CMakeLists.txt
+++ b/tracker-pt/CMakeLists.txt
@@ -1,7 +1,10 @@
find_package(OpenCV 3.0 QUIET)
if(OpenCV_FOUND)
- otr_module(tracker-pt)
+ otr_module(tracker-pt-base STATIC)
+ target_include_directories(opentrack-tracker-pt-base SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
+
set(modules opencv_core opencv_videoio opencv_imgproc)
+ otr_module(tracker-pt SOURCES module.cxx)
target_link_libraries(opentrack-tracker-pt opentrack-cv ${modules})
target_include_directories(opentrack-tracker-pt SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
endif()