summaryrefslogtreecommitdiffhomepage
path: root/tracker-pt/module/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2021-10-04 15:53:26 +0200
committerStanislaw Halik <sthalik@misaki.pl>2021-10-04 15:53:26 +0200
commitc2ab96e976ff12f1d5fdaefbb77042c024cb47dd (patch)
tree17331de17772210824e979a533836230579b1230 /tracker-pt/module/CMakeLists.txt
parenta790e295b544bceb067f3ea6c4f0fd93f225cb98 (diff)
tracker/{aruco,easy,pt,wii}, video/opencv: allow dynamic opencv
Diffstat (limited to 'tracker-pt/module/CMakeLists.txt')
-rw-r--r--tracker-pt/module/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tracker-pt/module/CMakeLists.txt b/tracker-pt/module/CMakeLists.txt
index cc16cba1..c5670404 100644
--- a/tracker-pt/module/CMakeLists.txt
+++ b/tracker-pt/module/CMakeLists.txt
@@ -1,6 +1,9 @@
include(opentrack-opencv)
find_package(OpenCV QUIET)
if(OpenCV_FOUND)
+ foreach(k core imgproc)
+ otr_install_lib("opencv_${k}" "${opentrack-libexec}")
+ endforeach()
otr_module(tracker-pt)
target_link_libraries(${self} opencv_imgproc opentrack-tracker-pt-base)
target_include_directories(${self} PUBLIC "${CMAKE_SOURCE_DIR}/tracker-pt")