summaryrefslogtreecommitdiffhomepage
path: root/tracker-steamvr/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2017-03-28 23:51:27 +0200
committerStanislaw Halik <sthalik@misaki.pl>2017-03-28 23:51:27 +0200
commit68b8813965cdead743a70e8ee47458d8f1e21dd4 (patch)
tree8f6348420f092889b1f6567b827e001952e8cf46 /tracker-steamvr/CMakeLists.txt
parentf7e66633b3906c90342ff1bd857ab9b3d63dab8e (diff)
tracker/steamvr: fix vive rotation order
Submitted-by: @subnet- Issue: #353 cf. https://github.com/opentrack/opentrack/issues/352#issuecomment-289306146 The submitter's working on the roll code. sin^1 codomain is +-90 deg. so we better use the equivalent atan2(3) formula.
Diffstat (limited to 'tracker-steamvr/CMakeLists.txt')
-rw-r--r--tracker-steamvr/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tracker-steamvr/CMakeLists.txt b/tracker-steamvr/CMakeLists.txt
index 36be2f13..512a49ff 100644
--- a/tracker-steamvr/CMakeLists.txt
+++ b/tracker-steamvr/CMakeLists.txt
@@ -27,8 +27,8 @@ endif()
if(steamvr-dll)
SET(SDK_VALVE_STEAMVR "" CACHE PATH "Valve's SteamVR")
if(SDK_VALVE_STEAMVR)
- otr_module(tracker-steamvr NO-INSTALL)
- #install(FILES "${SDK_VALVE_STEAMVR}/bin/${steamvr-dir}/${steamvr-dll}" DESTINATION "${opentrack-hier-pfx}")
+ otr_module(tracker-steamvr)
+ install(FILES "${SDK_VALVE_STEAMVR}/bin/${steamvr-dir}/${steamvr-dll}" DESTINATION "${opentrack-hier-pfx}")
target_include_directories(opentrack-tracker-steamvr SYSTEM PUBLIC "${SDK_VALVE_STEAMVR}/headers")
target_link_libraries(opentrack-tracker-steamvr "${SDK_VALVE_STEAMVR}/lib/${steamvr-dir}/${steamvr-lib}")