summaryrefslogtreecommitdiffhomepage
path: root/tracker-tobii-eyex/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2018-07-31 12:38:27 +0200
committerStanislaw Halik <sthalik@misaki.pl>2018-07-31 12:38:27 +0200
commit5b9ccf5164199804b6574b40914ee77baf0b6a78 (patch)
tree49659924d357c80d0ae22209bef3b0271c8e68a7 /tracker-tobii-eyex/CMakeLists.txt
parent1e108eb2fd484f62a55041a2d538b8e51bb297e7 (diff)
tracker/tobii-eyex: remove obsolete code
The API is obsolete as well as the device.
Diffstat (limited to 'tracker-tobii-eyex/CMakeLists.txt')
-rw-r--r--tracker-tobii-eyex/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/tracker-tobii-eyex/CMakeLists.txt b/tracker-tobii-eyex/CMakeLists.txt
deleted file mode 100644
index b1dcb056..00000000
--- a/tracker-tobii-eyex/CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-if(WIN32)
- set(SDK_TOBII_EYEX "" CACHE PATH "")
- if(SDK_TOBII_EYEX)
- otr_module(tracker-tobii-eyex)
- set(tobii-libdir ${SDK_TOBII_EYEX}/lib/x86/)
- set(tobii-dll "${tobii-libdir}/Tobii.EyeX.Client.dll")
- # we only care about the .lib for MSVC++ build anyway
- target_link_libraries(${self} "${tobii-libdir}/Tobii.EyeX.Client.lib")
- # we only ever use the C headers due to Microsoft CRT ABI incompatibility with GNU
- target_include_directories(${self} SYSTEM PUBLIC "${SDK_TOBII_EYEX}/include/eyex")
-
- install(FILES "${tobii-dll}" DESTINATION "${opentrack-hier-pfx}" PERMISSIONS ${opentrack-perms-exec})
- if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Windows")
- file(TO_CMAKE_PATH "$ENV{SystemRoot}" sysroot)
- if (IS_DIRECTORY "${sysroot}/SysWOW64")
- set(src "${sysroot}/SysWOW64")
- else()
- set(src "${sysroot}/System32")
- endif()
- install(FILES "${src}/msvcp110.dll" DESTINATION ${opentrack-hier-pfx} PERMISSIONS ${opentrack-perms-exec})
- install(FILES "${src}/msvcr110.dll" DESTINATION ${opentrack-hier-pfx} PERMISSIONS ${opentrack-perms-exec})
- endif()
- endif()
-endif()