summaryrefslogtreecommitdiffhomepage
path: root/tracker-tobii-eyex/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2017-10-31 21:04:44 +0100
committerStanislaw Halik <sthalik@misaki.pl>2017-10-31 21:04:44 +0100
commitd971b9d699f7862b4c9414abfdb64445f4be9018 (patch)
treef61d31339f1d824b213979d4cabd5b20cdf5358b /tracker-tobii-eyex/CMakeLists.txt
parent74253af3f832df22a742761a5f5a1454f1cc3c9b (diff)
tracker/tobii: set up settings for prototype vesion
The initial version won't have a generalized spline with multiple parameters to configure the gain. But it's doable in one go unlike a fully-fledged version from the start.
Diffstat (limited to 'tracker-tobii-eyex/CMakeLists.txt')
-rw-r--r--tracker-tobii-eyex/CMakeLists.txt36
1 files changed, 13 insertions, 23 deletions
diff --git a/tracker-tobii-eyex/CMakeLists.txt b/tracker-tobii-eyex/CMakeLists.txt
index 6d133f1d..eead67bf 100644
--- a/tracker-tobii-eyex/CMakeLists.txt
+++ b/tracker-tobii-eyex/CMakeLists.txt
@@ -1,34 +1,24 @@
if(WIN32)
set(SDK_TOBII_EYEX "" CACHE PATH "")
if(SDK_TOBII_EYEX)
- if(CMAKE_COMPILER_IS_GNUCXX)
- add_definitions(-Wno-error)
- endif()
- set(porked NO-INSTALL)
- otr_module(tracker-tobii-eyex ${porked})
- target_link_libraries(opentrack-tracker-tobii-eyex opentrack-spline)
+ otr_module(tracker-tobii)
set(tobii-libdir ${SDK_TOBII_EYEX}/lib/x86/)
- set(tobii-dll ${tobii-libdir}/Tobii.EyeX.Client.dll)
+ set(tobii-dll "${tobii-libdir}/Tobii.EyeX.Client.dll")
# we only care about the .lib for MSVC++ build anyway
- set(tobii-link ${tobii-libdir}/Tobii.EyeX.Client.lib)
- target_include_directories(opentrack-tracker-tobii-eyex PRIVATE ${CMAKE_SOURCE_DIR}/spline)
- target_link_libraries(opentrack-tracker-tobii-eyex ${tobii-link} opentrack-spline)
+ target_link_libraries(opentrack-tracker-tobii "${tobii-libdir}/Tobii.EyeX.Client.lib")
# we only ever use the C headers due to Microsoft CRT ABI incompatibility with GNU
- set(tobii-incdir ${SDK_TOBII_EYEX}/include/eyex)
- target_include_directories(opentrack-tracker-tobii-eyex SYSTEM PUBLIC ${tobii-incdir})
+ target_include_directories(opentrack-tracker-tobii SYSTEM PUBLIC "${SDK_TOBII_EYEX}/include/eyex")
- if(NOT "!${porked}" STREQUAL "!NO-INSTALL")
- install(FILES ${tobii-dll} DESTINATION ${opentrack-hier-pfx} ${opentrack-perms-exec})
- if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Windows")
- file(TO_CMAKE_PATH "$ENV{SystemRoot}" sysroot)
- if (IS_DIRECTORY "${sysroot}/SysWOW64")
- set(src "${sysroot}/SysWOW64")
- else()
- set(src "${sysroot}/System32")
- endif()
- install(FILES "${src}/msvcp110.dll" DESTINATION ${opentrack-hier-pfx} PERMISSIONS ${opentrack-perms-exec})
- install(FILES "${src}/msvcr110.dll" DESTINATION ${opentrack-hier-pfx} PERMISSIONS ${opentrack-perms-exec})
+ install(FILES "${tobii-dll}" DESTINATION "${opentrack-hier-pfx}" PERMISSIONS ${opentrack-perms-exec})
+ if(CMAKE_HOST_SYSTEM_NAME STREQUAL "Windows")
+ file(TO_CMAKE_PATH "$ENV{SystemRoot}" sysroot)
+ if (IS_DIRECTORY "${sysroot}/SysWOW64")
+ set(src "${sysroot}/SysWOW64")
+ else()
+ set(src "${sysroot}/System32")
endif()
+ install(FILES "${src}/msvcp110.dll" DESTINATION ${opentrack-hier-pfx} PERMISSIONS ${opentrack-perms-exec})
+ install(FILES "${src}/msvcr110.dll" DESTINATION ${opentrack-hier-pfx} PERMISSIONS ${opentrack-perms-exec})
endif()
endif()
endif()