summaryrefslogtreecommitdiffhomepage
path: root/video-ps3eye/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2019-07-05 13:04:58 +0200
committerStanislaw Halik <sthalik@misaki.pl>2019-07-05 13:04:58 +0200
commit8fa10fda8186b6cdd10430e4d6cb4ef8db1ee9a0 (patch)
treea5ee2b1e1d54944492776329ba71800070c72135 /video-ps3eye/CMakeLists.txt
parent66c2373014fc107d918b8549d554420d63405cc7 (diff)
video/ps3eye: stub
Diffstat (limited to 'video-ps3eye/CMakeLists.txt')
-rw-r--r--video-ps3eye/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/video-ps3eye/CMakeLists.txt b/video-ps3eye/CMakeLists.txt
index 5e45eb4a..6510d8c7 100644
--- a/video-ps3eye/CMakeLists.txt
+++ b/video-ps3eye/CMakeLists.txt
@@ -2,6 +2,23 @@ add_compile_definitions(PS3EYE_DEBUG)
add_subdirectory("ps3eye-driver")
+if(NOT MSVC)
+ if(PKG_CONFIG_FOUND)
+ pkg_check_modules(libusb "libusb-1.0" QUIET)
+ endif()
+ if(libusb_FOUND)
+ include_directories(SYSTEM ${libusb_INCLUDE_DIRS})
+ link_libraries(${libusb_LIBRARIES})
+ endif()
+else()
+ set(SDK_LIBUSB CACHE PATH "")
+ if(SDK_LIBUSB)
+ set(libusb_FOUND TRUE)
+ link_directories("${SDK_LIBUSB}")
+ include_directories(SYSTEM "${SDK_LIBUSB}")
+ endif()
+endif()
+
if(TARGET ps3eye-driver)
otr_module(video-ps3eye)
if(WIN32)