summaryrefslogtreecommitdiffhomepage
path: root/video/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2019-02-11 18:35:24 +0100
committerStanislaw Halik <sthalik@misaki.pl>2019-02-11 20:21:04 +0100
commit15a8ad060653a521bcd175b495455a0e09377050 (patch)
tree03ffc76a92ba44aee55a7974de83973ec11d97c9 /video/CMakeLists.txt
parent2e946e830ae52b19973745b8d67915cd0d8c767b (diff)
cv/video-widget: make it work without opencv
Diffstat (limited to 'video/CMakeLists.txt')
-rw-r--r--video/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/video/CMakeLists.txt b/video/CMakeLists.txt
new file mode 100644
index 00000000..5720bf60
--- /dev/null
+++ b/video/CMakeLists.txt
@@ -0,0 +1,7 @@
+find_package(OpenCV QUIET)
+otr_module(video STATIC)
+if(OpenCV_FOUND)
+ target_compile_definitions(${self} PUBLIC -DOTR_HAS_OPENCV)
+ target_link_libraries(${self} opencv_videoio opencv_core)
+endif()
+