summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c00735a2..1360fb11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,12 @@ include(opentrack-policy NO_POLICY_SCOPE)
project(opentrack)
cmake_minimum_required(VERSION 3.10 FATAL_ERROR)
+if(POLICY CMP0083)
+ cmake_policy(SET CMP0083 NEW)
+ include(CheckPIESupported)
+ check_pie_supported()
+endif()
+
include(CMakeDetermineCCompiler)
include(CMakeDetermineCXXCompiler)
include(CMakeParseArguments)