summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffb1c384..8ae29e4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,10 +22,15 @@ endif()
IF(WIN32)
SET(SDK_SM_FACEAPI_PATH "" CACHE PATH "SeeingMachines FaceAPI SDK path")
SET(SDK_RIFT "" CACHE PATH "libOVR path")
+ SET(SDK_RIFT_RECENTRE_SPRING TRUE CACHE BOOL "recenter yaw aggressively")
SET(SDK_HYDRA "" CACHE PATH "libSixense path")
SET(SDK_VJOY "" CACHE PATH "VJoy SDK path")
ENDIF()
+if(SDK_RIFT_RECENTRE_SPRING)
+ add_definitions(-DOPENTRACK_RIFT_RECENTRE_SPRING)
+endif()
+
file(GLOB opentrack-faceapi-wrapper-c "faceapi/*.cpp")
include_directories(${CMAKE_SOURCE_DIR})