summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2353d70..741d0c0d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,8 +5,8 @@ include(opentrack-build)
project(opentrack C CXX)
cmake_minimum_required(VERSION 2.8.11)
-include(opentrack-hier)
include(opentrack-word-size)
+include(opentrack-hier)
include(opentrack-policy)
include(opentrack-qt)
include(opentrack-platform)
@@ -14,6 +14,8 @@ include(opentrack-boilerplate)
include(opentrack-version)
include(opentrack-install)
+add_custom_target(mrproper COMMAND cmake -P "${CMAKE_SOURCE_DIR}/cmake/opentrack-clean-build-directory.cmake" WORKING_DIRECTORY "${CMAKE_BINARY_DIR}")
+
set(C CMakeLists.txt)
file(GLOB opentrack-subprojects
"tracker-*/${C}"