summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 4 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 776473b6..149dfc21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -308,21 +308,11 @@ if(WIN32)
set(my-qt-deps ws2_32)
endif()
-if(APPLE)
- link_directories(${CMAKE_INSTALL_PREFIX})
- set(maybe-hatire)
- if(SDK_HATIRE)
- set(maybe-hatire Qt5SerialPort)
- endif()
- set(MY_QT_LIBS Qt5Widgets Qt5Gui Qt5Network Qt5Xml Qt5Core ${maybe-hatire} ${my-qt-deps})
-else()
- set(maybe-hatire)
- if(SDK_HATIRE)
- set(maybe-hatire ${Qt5SerialPort_LIBRARIES})
- endif()
- SET(MY_QT_LIBS ${Qt5Widgets_LIBRARIES} ${Qt5Gui_LIBRARIES}
- ${Qt5Network_LIBRARIES} ${Qt5Xml_LIBRARIES} ${Qt5Core_LIBRARIES} ${maybe-hatire} ${my-qt-deps})
+set(maybe-hatire)
+if(SDK_HATIRE)
+set(maybe-hatire ${Qt5SerialPort_LIBRARIES})
endif()
+set(MY_QT_LIBS ${Qt5Widgets_LIBRARIES} ${Qt5Gui_LIBRARIES} ${Qt5Network_LIBRARIES} ${Qt5Xml_LIBRARIES} ${Qt5Core_LIBRARIES} ${maybe-hatire} ${my-qt-deps})
add_library(opentrack-csv SHARED ${opentrack-csv-c})
target_link_libraries(opentrack-csv ${MY_QT_LIBS})