summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93e0b415..e6efa07d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -443,14 +443,18 @@ if(SDK_RIFT)
include_directories("${SDK_RIFT}/Include")
include_directories("${SDK_RIFT}/Src")
set(link-flags)
+ set(c-flags)
if(APPLE)
set(link-flags "-framework CoreFoundation -framework CoreGraphics -framework IOKit -framework Quartz")
+ set(c-flags "-fno-strict-aliasing")
else()
if(MSVC)
set(link-flags "/NODEFAULTLIB:LIBCMT")
+ else()
+ set(c-flags "-fno-strict-aliasing")
endif()
endif()
- opentrack_library(opentrack-tracker-rift LINK "${link-flags}")
+ opentrack_library(opentrack-tracker-rift LINK "${link-flags}" COMPILE "${c-flags}")
if(MSVC)
target_link_libraries(opentrack-tracker-rift "${SDK_RIFT}/Lib/Win32/libovr.lib" winmm.lib setupapi.lib)
else()