summaryrefslogtreecommitdiffhomepage
path: root/compat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compat/CMakeLists.txt')
-rw-r--r--compat/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/compat/CMakeLists.txt b/compat/CMakeLists.txt
new file mode 100644
index 00000000..2bbb496c
--- /dev/null
+++ b/compat/CMakeLists.txt
@@ -0,0 +1,8 @@
+opentrack_boilerplate(opentrack-compat NO-COMPAT BIN)
+if(NOT WIN32 AND NOT APPLE)
+ target_link_libraries(opentrack-compat rt)
+endif()
+if(CMAKE_COMPILER_IS_GNUCXX)
+ set_source_files_properties(nan.cpp PROPERTIES
+ COMPILE_FLAGS "-fno-fast-math -fno-finite-math-only -O0")
+endif()