summaryrefslogtreecommitdiffhomepage
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
new file mode 100644
index 00000000..627501ea
--- /dev/null
+++ b/main/CMakeLists.txt
@@ -0,0 +1,8 @@
+otr_module(executable EXECUTABLE BIN)
+
+set_target_properties(opentrack-user-interface PROPERTIES
+ SUFFIX "${opentrack-binary-suffix}"
+ OUTPUT_NAME "opentrack"
+)
+
+target_link_libraries(opentrack-executable opentrack-user-interface)