summaryrefslogtreecommitdiffhomepage
path: root/opentrack-compat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'opentrack-compat/CMakeLists.txt')
-rw-r--r--opentrack-compat/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/opentrack-compat/CMakeLists.txt b/opentrack-compat/CMakeLists.txt
index 6f745701..2bbb496c 100644
--- a/opentrack-compat/CMakeLists.txt
+++ b/opentrack-compat/CMakeLists.txt
@@ -2,3 +2,7 @@ opentrack_boilerplate(opentrack-compat NO-COMPAT BIN)
if(NOT WIN32 AND NOT APPLE)
target_link_libraries(opentrack-compat rt)
endif()
+if(CMAKE_COMPILER_IS_GNUCXX)
+ set_source_files_properties(nan.cpp PROPERTIES
+ COMPILE_FLAGS "-fno-fast-math -fno-finite-math-only -O0")
+endif()