summaryrefslogtreecommitdiffhomepage
path: root/opentrack/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'opentrack/CMakeLists.txt')
-rw-r--r--opentrack/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/opentrack/CMakeLists.txt b/opentrack/CMakeLists.txt
index a8829aa5..0fd72475 100644
--- a/opentrack/CMakeLists.txt
+++ b/opentrack/CMakeLists.txt
@@ -1,3 +1,8 @@
+if(MSVC)
+ add_compile_options(-EHsc)
+ add_definitions(-D_HAS_EXCEPTIONS=1)
+endif()
+
otr_module(executable EXECUTABLE BIN)
set_target_properties(opentrack-executable PROPERTIES
@@ -6,4 +11,15 @@ set_target_properties(opentrack-executable PROPERTIES
PREFIX ""
)
+set_source_files_properties(resources.rc OBJECT_DEPENDS "${CMAKE_CURRENT_SOURCE_DIR}/opentrack.ico")
+
+if(APPLE)
+ set_source_files_properties(appnap_mac.mm PROPERTIES COMPILE_FLAGS "-fno-objc-arc")
+ target_sources(${self} PRIVATE appnap_mac.mm)
+endif()
+
target_link_libraries(${self} opentrack-user-interface opentrack-version)
+
+if(APPLE)
+ target_link_libraries(${self} "-framework Foundation")
+endif()