summaryrefslogtreecommitdiffhomepage
path: root/opentrack/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'opentrack/CMakeLists.txt')
-rw-r--r--opentrack/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/opentrack/CMakeLists.txt b/opentrack/CMakeLists.txt
index a8829aa5..7a83beb6 100644
--- a/opentrack/CMakeLists.txt
+++ b/opentrack/CMakeLists.txt
@@ -1,3 +1,8 @@
+if(MSVC)
+ add_compile_options(-EHsc)
+ add_definitions(-D_HAS_EXCEPTIONS=1)
+endif()
+
otr_module(executable EXECUTABLE BIN)
set_target_properties(opentrack-executable PROPERTIES