summaryrefslogtreecommitdiffhomepage
path: root/proto-libevdev/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'proto-libevdev/CMakeLists.txt')
-rw-r--r--proto-libevdev/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/proto-libevdev/CMakeLists.txt b/proto-libevdev/CMakeLists.txt
index 04f6924e..d6cd4560 100644
--- a/proto-libevdev/CMakeLists.txt
+++ b/proto-libevdev/CMakeLists.txt
@@ -1,9 +1,8 @@
-if(LINUX OR APPLE)
- set(SDK_ENABLE_LIBEVDEV FALSE CACHE BOOL "libevdev virtual joystick protocol support")
- if(SDK_ENABLE_LIBEVDEV)
- include(FindPkgConfig)
+if(LINUX)
+ include(FindPkgConfig)
+ pkg_check_modules(libevdev QUIET libevdev)
+ if(libevdev_FOUND)
otr_module(proto-libevdev)
- pkg_check_modules(libevdev REQUIRED QUIET libevdev)
target_link_libraries(opentrack-proto-libevdev ${libevdev_LIBRARIES})
target_include_directories(opentrack-proto-libevdev SYSTEM PUBLIC ${libevdev_INCLUDE_DIRS})
endif()