summaryrefslogtreecommitdiffhomepage
path: root/proto-wine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'proto-wine/CMakeLists.txt')
-rw-r--r--proto-wine/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/proto-wine/CMakeLists.txt b/proto-wine/CMakeLists.txt
index f949d1ad..780b1e16 100644
--- a/proto-wine/CMakeLists.txt
+++ b/proto-wine/CMakeLists.txt
@@ -3,13 +3,13 @@ if(NOT WIN32)
set(SDK_WINE_NO_WRAPPER FALSE CACHE BOOL "disable Wine wrapper -- use Wine only for X-Plane")
if(SDK_WINE_PREFIX)
opentrack_boilerplate(opentrack-proto-wine)
- opentrack_link(opentrack-proto-wine opentrack-compat opentrack-csv)
+ target_link_libraries(opentrack-proto-wine opentrack-csv)
if(NOT SDK_WINE_NO_WRAPPER)
set(my-rt -lrt)
if(APPLE)
set(my-rt)
endif()
- file(GLOB wine-deps ${PROJECT_SOURCE_DIR}/*.cxx)
+ file(GLOB wine-deps "${CMAKE_CURRENT_SOURCE_DIR}/*.cxx")
install(FILES ${wine-deps} DESTINATION "${opentrack-doc-src-pfx}/proto-wine")
add_custom_command(
OUTPUT opentrack-wrapper-wine.exe.so
@@ -24,5 +24,4 @@ if(NOT WIN32)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/opentrack-wrapper-wine.exe.so" DESTINATION ${opentrack-hier-pfx})
endif()
endif()
- opentrack_register(opentrack-proto-wine)
endif()