summaryrefslogtreecommitdiffhomepage
path: root/protocol-fsuipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocol-fsuipc/CMakeLists.txt')
-rw-r--r--protocol-fsuipc/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/protocol-fsuipc/CMakeLists.txt b/protocol-fsuipc/CMakeLists.txt
new file mode 100644
index 00000000..ec897ae8
--- /dev/null
+++ b/protocol-fsuipc/CMakeLists.txt
@@ -0,0 +1,11 @@
+if(WIN32)
+ set(SDK_FSUIPC "" CACHE PATH "FSUIPC for older MS FSX path")
+ if(SDK_FSUIPC)
+ opentrack_boilerplate(opentrack-proto-fsuipc)
+ target_link_libraries(opentrack-proto-fsuipc ${SDK_FSUIPC}/FSUIPC_User.lib)
+ target_include_directories(opentrack-proto-fsuipc SYSTEM PUBLIC ${SDK_FSUIPC})
+ if(MSVC)
+ set_target_properties(opentrack-proto-fsuipc PROPERTIES LINK_FLAGS "/NODEFAULTLIB:LIBC.lib")
+ endif()
+ endif()
+endif()