summaryrefslogtreecommitdiffhomepage
path: root/protocol-vjoy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocol-vjoy/CMakeLists.txt')
-rw-r--r--protocol-vjoy/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/protocol-vjoy/CMakeLists.txt b/protocol-vjoy/CMakeLists.txt
new file mode 100644
index 00000000..22678c32
--- /dev/null
+++ b/protocol-vjoy/CMakeLists.txt
@@ -0,0 +1,14 @@
+if(WIN32)
+ set(SDK_VJOY "" CACHE PATH "VJoy SDK path")
+ if(SDK_VJOY)
+ opentrack_boilerplate(opentrack-proto-vjoy GNU-LINK "-Wl,--enable-stdcall-fixup")
+ if(MSVC)
+ set(ext .lib)
+ else()
+ set(ext .dll)
+ endif()
+ target_link_libraries(opentrack-proto-vjoy ${MY_QT_LIBS} ${SDK_VJOY}/VJoy${ext})
+ target_include_directories(opentrack-proto-vjoy SYSTEM PUBLIC ${SDK_VJOY})
+ install(FILES "${SDK_VJOY}/VJoy.dll" DESTINATION . ${opentrack-perms})
+ endif()
+endif()