summaryrefslogtreecommitdiffhomepage
path: root/protocol-wine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocol-wine/CMakeLists.txt')
-rw-r--r--protocol-wine/CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/protocol-wine/CMakeLists.txt b/protocol-wine/CMakeLists.txt
deleted file mode 100644
index bafcff8b..00000000
--- a/protocol-wine/CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-if(NOT WIN32)
- set(SDK_WINE_PREFIX "" CACHE PATH "Wine install prefix")
- set(SDK_WINE_NO_WRAPPER FALSE CACHE BOOL "disable Wine wrapper -- use Wine only for X-Plane")
- if(SDK_WINE_PREFIX)
- opentrack_boilerplate(opentrack-proto-wine)
- target_link_libraries(opentrack-proto-wine opentrack-compat opentrack-csv)
- if(NOT SDK_WINE_NO_WRAPPER)
- set(my-rt -lrt)
- if(APPLE)
- set(my-rt)
- endif()
- file(GLOB wine-deps ${PROJECT_SOURCE_DIR}/*.cxx)
- add_custom_command(
- OUTPUT opentrack-wrapper-wine.exe.so
- DEPENDS ${wine-deps}
- COMMAND ${SDK_WINE_PREFIX}/bin/wineg++ -g -DNOMINMAX -O2 -m32 -std=c++11 -o
- opentrack-wrapper-wine.exe -I "${CMAKE_SOURCE_DIR}"
- ${wine-deps}
- ${my-rt})
- add_custom_target(wine-wrapper ALL DEPENDS opentrack-wrapper-wine.exe.so)
- add_dependencies(opentrack-proto-wine wine-wrapper)
- add_dependencies(wine-wrapper opentrack-compat)
- install(FILES "${CMAKE_BINARY_DIR}/opentrack-wrapper-wine.exe.so" DESTINATION .)
- endif()
- endif()
-endif()