summaryrefslogtreecommitdiffhomepage
path: root/qxt-mini/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qxt-mini/CMakeLists.txt')
-rw-r--r--qxt-mini/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/qxt-mini/CMakeLists.txt b/qxt-mini/CMakeLists.txt
index cc73e6a4..f355b943 100644
--- a/qxt-mini/CMakeLists.txt
+++ b/qxt-mini/CMakeLists.txt
@@ -1,11 +1,10 @@
if(UNIX OR APPLE)
set(self opentrack-qxt-mini)
otr_module(qxt-mini NO-COMPAT BIN)
- otr_pkgconfig(${self} x11 xcb xproto)
if(APPLE)
- set_property(TARGET ${self}
- APPEND_STRING PROPERTY
- LINK_FLAGS " -framework Carbon -framework CoreFoundation ")
+ target_link_options(${self} PUBLIC -framework Carbon -framework CoreFoundation)
+ else()
+ otr_pkgconfig(${self} x11 xcb xproto)
endif()
target_compile_definitions(${self} PRIVATE -DQXT_BUILD)
endif()