summaryrefslogtreecommitdiffhomepage
path: root/qxt-mini/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qxt-mini/CMakeLists.txt')
-rw-r--r--qxt-mini/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/qxt-mini/CMakeLists.txt b/qxt-mini/CMakeLists.txt
index 21b2b160..1b2496f6 100644
--- a/qxt-mini/CMakeLists.txt
+++ b/qxt-mini/CMakeLists.txt
@@ -3,7 +3,9 @@ if(UNIX OR APPLE)
include_directories(SYSTEM ${Qt5Gui_PRIVATE_INCLUDE_DIRS})
otr_module(qxt-mini NO-COMPAT BIN)
if(APPLE)
- target_link_options(${self} PUBLIC -framework Carbon -framework CoreFoundation)
+ find_library(CoreFoundation CoreFoundation)
+ find_library(Carbon Carbon)
+ target_link_options(${self} PUBLIC -framework Carbon -I ${CoreFoundation})
else()
otr_pkgconfig(${self} x11 xcb xproto)
endif()