summaryrefslogtreecommitdiffhomepage
path: root/qxt-mini/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qxt-mini/CMakeLists.txt')
-rw-r--r--qxt-mini/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/qxt-mini/CMakeLists.txt b/qxt-mini/CMakeLists.txt
index a6c2908e..84e66732 100644
--- a/qxt-mini/CMakeLists.txt
+++ b/qxt-mini/CMakeLists.txt
@@ -1,6 +1,8 @@
if(UNIX OR APPLE)
otr_module(qxt-mini NO-COMPAT BIN)
if(NOT APPLE)
+ pkg_check_modules(xprotopkg REQUIRED xproto)
+ target_include_directories(opentrack-qxt-mini SYSTEM PRIVATE ${xprotopkg_INCLUDE_DIRS})
target_link_libraries(opentrack-qxt-mini X11)
else()
otr_prop(TARGET opentrack-qxt-mini LINK_FLAGS "-framework Carbon -framework CoreFoundation")