summaryrefslogtreecommitdiffhomepage
path: root/tracker-easy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-easy/CMakeLists.txt')
-rw-r--r--tracker-easy/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tracker-easy/CMakeLists.txt b/tracker-easy/CMakeLists.txt
index c377dd9c..ff537877 100644
--- a/tracker-easy/CMakeLists.txt
+++ b/tracker-easy/CMakeLists.txt
@@ -5,17 +5,17 @@ if(OpenCV_FOUND)
try_compile(tracker-easy_ocv-check "${CMAKE_CURRENT_BINARY_DIR}"
SOURCES "${CMAKE_CURRENT_SOURCE_DIR}/ocv-check.cxx"
CMAKE_FLAGS "-DINCLUDE_DIRECTORIES=${OpenCV_INCLUDE_DIRS}"
- "-DCXX_STANDARD=17" "-DCXX_STANDARD_REQUIRED=1"
+ "-DCXX_STANDARD=20" "-DCXX_STANDARD_REQUIRED=1"
OUTPUT_VARIABLE krap)
if(tracker-easy_ocv-check)
- foreach(k video highgui)
+ foreach(k highgui videoio imgcodecs imgproc calib3d video features2d flann)
otr_install_lib("opencv_${k}" "${opentrack-libexec}")
endforeach()
if(CMAKE_COMPILER_IS_GNUCXX)
add_compile_options(-Wno-sign-compare)
elseif(MSVC)
- add_compile_definitions(-wd4018)
+ add_compile_options(-wd4018)
endif()
otr_module(tracker-easy)