summaryrefslogtreecommitdiffhomepage
path: root/tracker-easy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-easy/CMakeLists.txt')
-rw-r--r--tracker-easy/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tracker-easy/CMakeLists.txt b/tracker-easy/CMakeLists.txt
index 2bc773d7..670b9003 100644
--- a/tracker-easy/CMakeLists.txt
+++ b/tracker-easy/CMakeLists.txt
@@ -12,6 +12,12 @@ if(OpenCV_FOUND)
otr_install_lib("opencv_${k}" "${opentrack-hier-pfx}")
endforeach()
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ add_compile_options(-Wno-sign-compare)
+ elseif(MSVC)
+ add_compile_definitions(-wd4018)
+ endif()
+
otr_module(tracker-easy)
target_include_directories(${self} SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
target_link_libraries(${self} opencv_core opencv_imgproc opencv_calib3d opencv_video opencv_highgui opentrack-cv opentrack-video)