summaryrefslogtreecommitdiffhomepage
path: root/tracker-pt/module/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-pt/module/CMakeLists.txt')
-rw-r--r--tracker-pt/module/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tracker-pt/module/CMakeLists.txt b/tracker-pt/module/CMakeLists.txt
index 43580a1f..f0f90f8a 100644
--- a/tracker-pt/module/CMakeLists.txt
+++ b/tracker-pt/module/CMakeLists.txt
@@ -1,6 +1,8 @@
find_package(OpenCV QUIET)
if(OpenCV_FOUND)
+ otr_module(tracker-pt-static STATIC)
+ target_link_libraries(${self} opentrack-tracker-pt-base)
+ target_include_directories(${self} PUBLIC "${CMAKE_SOURCE_DIR}/tracker-pt")
otr_module(tracker-pt)
- target_link_libraries(opentrack-tracker-pt opentrack-tracker-pt-base)
- target_include_directories(opentrack-tracker-pt PRIVATE "${CMAKE_SOURCE_DIR}/tracker-pt")
+ target_link_libraries(${self} opentrack-tracker-pt-static)
endif()