summaryrefslogtreecommitdiffhomepage
path: root/tracker-rs/rs_impl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-rs/rs_impl/CMakeLists.txt')
-rw-r--r--tracker-rs/rs_impl/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tracker-rs/rs_impl/CMakeLists.txt b/tracker-rs/rs_impl/CMakeLists.txt
index 7148cdf1..d4bf0925 100644
--- a/tracker-rs/rs_impl/CMakeLists.txt
+++ b/tracker-rs/rs_impl/CMakeLists.txt
@@ -3,4 +3,12 @@ if(WIN32)
target_compile_definitions(opentrack-tracker-rs-impl PRIVATE -DUNICODE -D_UNICODE)
target_include_directories(opentrack-tracker-rs-impl PRIVATE SYSTEM "${SDK_REALSENSE}/include")
target_link_libraries(opentrack-tracker-rs-impl advapi32)
+
+ # for SDK headers
+ if(CMAKE_COMPILER_IS_GNUCC)
+ add_definitions(-fpermissive -Wno-error -w
+ #-Wno-missing-field-initializers -Wno-switch -Wno-sign-compare
+ #-Wno-unknown-pragmas -Wno-attributes
+ )
+ endif()
endif()