summaryrefslogtreecommitdiffhomepage
path: root/tracker-steamvr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-steamvr/CMakeLists.txt')
-rw-r--r--tracker-steamvr/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/tracker-steamvr/CMakeLists.txt b/tracker-steamvr/CMakeLists.txt
index 19832b11..dc487cba 100644
--- a/tracker-steamvr/CMakeLists.txt
+++ b/tracker-steamvr/CMakeLists.txt
@@ -21,8 +21,13 @@ if(WIN32)
set(steamvr-lib "openvr_api.lib")
endif()
-if(APPLE AND NOT opentrack-64bit)
- set(steamvr-dir "osx32")
+if(APPLE)
+ # expect user compiled it as a non-framework version
+ if(opentrack-64bit)
+ set(steamvr-dir "osx64")
+ else()
+ set(steamvr-dir "osx32")
+ endif()
set(steamvr-dll "libopenvr_api.dylib")
endif()