summaryrefslogtreecommitdiffhomepage
path: root/tracker-tobii/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-tobii/CMakeLists.txt')
-rw-r--r--tracker-tobii/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tracker-tobii/CMakeLists.txt b/tracker-tobii/CMakeLists.txt
new file mode 100644
index 00000000..4593ae4e
--- /dev/null
+++ b/tracker-tobii/CMakeLists.txt
@@ -0,0 +1,16 @@
+# https://developer.tobii.com/download-packages/stream-engine-4-1-0-for-windows-x86
+# https://developer.tobii.com/download-packages/stream-engine-4-1-0-for-windows-x64
+if(SDK_TOBII)
+ otr_module(tracker-tobii)
+ target_include_directories(${self} SYSTEM PRIVATE "${SDK_TOBII}/include")
+
+ set(dll "${SDK_TOBII}/lib/tobii/tobii_stream_engine.dll")
+ set(lib "${SDK_TOBII}/lib/tobii/tobii_stream_engine.lib")
+
+ message(${self})
+ message(${dll})
+ message(${lib})
+
+ install(FILES ${dll} DESTINATION ${opentrack-hier-pfx})
+ target_link_libraries(${self} ${lib})
+endif()