summaryrefslogtreecommitdiffhomepage
path: root/video-opencv/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'video-opencv/CMakeLists.txt')
-rw-r--r--video-opencv/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/video-opencv/CMakeLists.txt b/video-opencv/CMakeLists.txt
index c56e65d4..0b2460a4 100644
--- a/video-opencv/CMakeLists.txt
+++ b/video-opencv/CMakeLists.txt
@@ -2,8 +2,11 @@ include(opentrack-opencv)
find_package(OpenCV QUIET)
if(OpenCV_FOUND)
+ foreach(k core videoio imgcodecs imgproc)
+ otr_install_lib("opencv_${k}" "${opentrack-libexec}")
+ endforeach()
otr_module(video-opencv)
- target_link_libraries(${self} opencv_core opencv_videoio opentrack-video)
+ target_link_libraries(${self} opencv_core opencv_imgcodecs opencv_videoio opentrack-video)
if(WIN32)
target_link_libraries(${self} strmiids)
endif()