summaryrefslogtreecommitdiffhomepage
path: root/video/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'video/CMakeLists.txt')
-rw-r--r--video/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/video/CMakeLists.txt b/video/CMakeLists.txt
new file mode 100644
index 00000000..5720bf60
--- /dev/null
+++ b/video/CMakeLists.txt
@@ -0,0 +1,7 @@
+find_package(OpenCV QUIET)
+otr_module(video STATIC)
+if(OpenCV_FOUND)
+ target_compile_definitions(${self} PUBLIC -DOTR_HAS_OPENCV)
+ target_link_libraries(${self} opencv_videoio opencv_core)
+endif()
+