summaryrefslogtreecommitdiffhomepage
path: root/x-plane-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'x-plane-plugin/CMakeLists.txt')
-rw-r--r--x-plane-plugin/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/x-plane-plugin/CMakeLists.txt b/x-plane-plugin/CMakeLists.txt
index 1d686d98..1d985091 100644
--- a/x-plane-plugin/CMakeLists.txt
+++ b/x-plane-plugin/CMakeLists.txt
@@ -5,16 +5,16 @@ if(LINUX OR APPLE)
otr_module(xplane-plugin NO-QT)
# probably librt already included
#install(FILES ${opentrack-xplane-plugin-c} DESTINATION "${opentrack-doc-src-pfx}/opentrack-xplane-plugin")
- target_include_directories(opentrack-xplane-plugin SYSTEM PUBLIC ${SDK_XPLANE}/CHeaders ${SDK_XPLANE}/CHeaders/XPLM)
+ target_include_directories(opentrack-xplane-plugin SYSTEM PUBLIC ${SDK_XPLANE}/CHeaders/XPLM)
if(APPLE)
target_compile_options(${self} PRIVATE
-iframework "${SDK_XPLANE}/Libraries/Mac/"
- -DAPL -DXPLM200 -DXPLM210
- -framework XPLM -framework XPWidgets)
- target_link_options(${self}
+ -DAPL -DXPLM200 -DXPLM210
+ -framework XPLM)
+ target_link_options(${self} PRIVATE
"-F${SDK_XPLANE}/Libraries/Mac/"
- -framework XPLM -framework XPWidgets)
+ -framework XPLM)
elseif(CMAKE_COMPILER_IS_GNUCXX)
target_compile_options(${self} PRIVATE -DLIN -DXPLM200 -DXPLM210)
target_link_options(${self} PRIVATE -rdynamic -nodefaultlibs)