summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEnnio Barbaro <enniobarbaro@gmail.com>2015-07-02 22:08:40 +0200
committerEnnio Barbaro <enniobarbaro@gmail.com>2015-07-02 22:57:18 +0200
commit59144a96bf9e3391a32b9ad8f5240f02acb3f44a (patch)
tree6a36f3a7ce8f2b9efbd6dc9dbed32f4db32abb6f /CMakeLists.txt
parente94be88e28b41610bab983a1cbf8f31133a4ced8 (diff)
Use XPLMRegisterFlightLoopCallback instead of XPLMRegisterDrawCallback
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ec6dc54..4fb6e8d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,13 +199,13 @@ if(SDK_XPLANE)
SET_TARGET_PROPERTIES(opentrack-xplane-plugin
PROPERTIES LINK_FLAGS
"-Wl,--version-script=${CMAKE_SOURCE_DIR}/x-plane-plugin/version-script.txt -shared -rdynamic -nodefaultlibs -undefined_warning -fPIC"
- COMPILE_FLAGS "-Wall -O2 -pipe -fPIC -DLIN -DXPLM210"
+ COMPILE_FLAGS "-Wall -O2 -pipe -fPIC -DLIN -DXPLM200 -DXPLM210"
LIBRARY_OUTPUT_NAME "opentrack.xpl"
PREFIX "" SUFFIX "")
endif()
if(APPLE)
SET_TARGET_PROPERTIES(opentrack-xplane-plugin PROPERTIES
- COMPILE_FLAGS "-iframework ${SDK_XPLANE}/Libraries/Mac/ -DAPL -DXPLM210 -framework XPLM -framework XPWidgets"
+ COMPILE_FLAGS "-iframework ${SDK_XPLANE}/Libraries/Mac/ -DAPL -DXPLM200 -DXPLM210 -framework XPLM -framework XPWidgets"
LINK_FLAGS "-F${SDK_XPLANE}/Libraries/Mac/ -framework XPLM -framework XPWidgets")
endif()
if(UNIX AND NOT APPLE)