summaryrefslogtreecommitdiffhomepage
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-07-06 17:17:17 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-07-06 17:34:18 +0200
commite0507257a41c29fa2e9ac28f36470023a72c39c6 (patch)
tree6885274b79adedd7df561b1347c814ce0a4bfd30 /gui/CMakeLists.txt
parent9d5219724d4eddf1e96a4e4a421f645069dd504a (diff)
compat: fix linux procps
We'll actually support both libprocps and libproc2. What a mess.
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index bc9487b8..398223b3 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -11,7 +11,14 @@ target_link_libraries(${self}
if(APPLE)
target_link_libraries(${self} proc)
elseif(LINUX)
- otr_pkgconfig(${self} libproc2)
+ otr_pkgconfig_(has-libproc2 ${self} libproc2)
+ if(has-libproc2)
+ message(STATUS "!!!!! has libproc2")
+ target_compile_definitions(${self} PRIVATE -DOTR_HAS_LIBPROC2)
+ else()
+ message(STATUS "!!!!! no libproc2")
+ otr_pkgconfig(${self} libprocps)
+ endif()
endif()
if(NOT APPLE AND NOT WIN32)