summaryrefslogtreecommitdiffhomepage
path: root/proto-wine/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-05-09 15:34:38 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-05-09 15:34:38 +0200
commit780aca2622d907320a1cf462390f192fb3ae4b31 (patch)
treec7843a5ebe0620d8f97ae7ba86ba6f5d06ffc167 /proto-wine/CMakeLists.txt
parentc1de1499775d47a574bd52d07acbb269845fb75b (diff)
parent051fb2f94f6364b80219a3c671bb953d2e54a140 (diff)
Merge branch 'master' into trackhat-sensor-v2
Diffstat (limited to 'proto-wine/CMakeLists.txt')
-rw-r--r--proto-wine/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/proto-wine/CMakeLists.txt b/proto-wine/CMakeLists.txt
index 0beb50e1..ff4932cc 100644
--- a/proto-wine/CMakeLists.txt
+++ b/proto-wine/CMakeLists.txt
@@ -17,10 +17,14 @@ if(NOT WIN32)
endif()
file(GLOB wine-deps "${CMAKE_CURRENT_SOURCE_DIR}/*.cxx")
#install(FILES ${wine-deps} DESTINATION "${opentrack-src}/proto-wine")
+ set(winegxx-multilib "-m32")
+ if (NOT OPENTRACK_WINE_ARCH STREQUAL "")
+ set(winegxx-multilib "${OPENTRACK_WINE_ARCH}")
+ endif()
add_custom_command(
OUTPUT opentrack-wrapper-wine.exe.so
DEPENDS ${wine-deps}
- COMMAND wineg++ -mconsole -g -DNOMINMAX -O2 -m32 -std=c++17 -fPIC -o
+ COMMAND wineg++ -mconsole -g -DNOMINMAX -O2 ${winegxx-multilib} -std=c++17 -fPIC -o
opentrack-wrapper-wine.exe -I "${CMAKE_SOURCE_DIR}" -I "${CMAKE_BINARY_DIR}"
${wine-deps} -Wall -Wextra -Wpedantic
${my-rt})