summaryrefslogtreecommitdiffhomepage
path: root/proto-fsuipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'proto-fsuipc/CMakeLists.txt')
-rw-r--r--proto-fsuipc/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/proto-fsuipc/CMakeLists.txt b/proto-fsuipc/CMakeLists.txt
index 3ba2c90c..9b7bd77e 100644
--- a/proto-fsuipc/CMakeLists.txt
+++ b/proto-fsuipc/CMakeLists.txt
@@ -1,12 +1,11 @@
-if(WIN32)
+if(WIN32 AND NOT opentrack-64bit AND opentrack-intel)
set(SDK_FSUIPC "" CACHE PATH "FSUIPC for older MS FSX path")
if(SDK_FSUIPC)
otr_module(proto-fsuipc)
target_link_libraries(opentrack-proto-fsuipc ${SDK_FSUIPC}/FSUIPC_User.lib)
target_include_directories(opentrack-proto-fsuipc SYSTEM PUBLIC ${SDK_FSUIPC})
if(MSVC)
- set_property(TARGET opentrack-proto-fsuipc APPEND_STRING PROPERTY
- LINK_FLAGS "/NODEFAULTLIB:LIBC.lib ")
+ target_link_options(${self} PRIVATE -NODEFAULTLIB:LIBC.lib)
endif()
endif()
endif()