summaryrefslogtreecommitdiffhomepage
path: root/proto-iokit-foohid/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'proto-iokit-foohid/CMakeLists.txt')
-rw-r--r--proto-iokit-foohid/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/proto-iokit-foohid/CMakeLists.txt b/proto-iokit-foohid/CMakeLists.txt
index cdc8fb69..6a4bf89a 100644
--- a/proto-iokit-foohid/CMakeLists.txt
+++ b/proto-iokit-foohid/CMakeLists.txt
@@ -1,4 +1,4 @@
-IF(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+if(APPLE)
otr_module(proto-iokit-foohid)
- set_property(TARGET opentrack-proto-iokit-foohid APPEND_STRING PROPERTY LINK_FLAGS "-framework IOKit ")
+ target_link_options(${self} PRIVATE -framework IOKit)
endif()