summaryrefslogtreecommitdiffhomepage
path: root/proto-vjoy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'proto-vjoy/CMakeLists.txt')
-rw-r--r--proto-vjoy/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/proto-vjoy/CMakeLists.txt b/proto-vjoy/CMakeLists.txt
index 22678c32..5584c876 100644
--- a/proto-vjoy/CMakeLists.txt
+++ b/proto-vjoy/CMakeLists.txt
@@ -1,7 +1,11 @@
if(WIN32)
set(SDK_VJOY "" CACHE PATH "VJoy SDK path")
if(SDK_VJOY)
- opentrack_boilerplate(opentrack-proto-vjoy GNU-LINK "-Wl,--enable-stdcall-fixup")
+ set(link "")
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ set(link "-Wl,--enable-stdcall-fixup")
+ endif()
+ opentrack_boilerplate(opentrack-proto-vjoy LINK "${link}")
if(MSVC)
set(ext .lib)
else()