summaryrefslogtreecommitdiffhomepage
path: root/proto-wine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'proto-wine/CMakeLists.txt')
-rw-r--r--proto-wine/CMakeLists.txt30
1 files changed, 20 insertions, 10 deletions
diff --git a/proto-wine/CMakeLists.txt b/proto-wine/CMakeLists.txt
index 629f47f3..ff4932cc 100644
--- a/proto-wine/CMakeLists.txt
+++ b/proto-wine/CMakeLists.txt
@@ -1,27 +1,37 @@
if(NOT WIN32)
- set(SDK_WINE_PREFIX "" CACHE PATH "Wine install prefix")
- set(SDK_WINE_NO_WRAPPER FALSE CACHE BOOL "disable Wine wrapper -- use Wine only for X-Plane")
- if(SDK_WINE_PREFIX)
+ set(SDK_WINE "" CACHE BOOL "Build for Wine")
+ set(no-wrapper FALSE)
+ if(NOT SDK_WINE AND SDK_XPLANE)
+ set(no-wrapper TRUE)
+ endif()
+ if(SDK_WINE OR no-wrapper)
+ if(no-wrapper)
+ add_definitions(-DOTR_WINE_NO_WRAPPER)
+ endif()
otr_module(proto-wine)
- target_link_libraries(opentrack-proto-wine opentrack-csv)
- if(NOT SDK_WINE_NO_WRAPPER)
+ if(NOT no-wrapper)
+ target_link_libraries(opentrack-proto-wine opentrack-csv)
set(my-rt -lrt)
if(APPLE)
set(my-rt)
endif()
file(GLOB wine-deps "${CMAKE_CURRENT_SOURCE_DIR}/*.cxx")
- install(FILES ${wine-deps} DESTINATION "${opentrack-doc-src-pfx}/proto-wine")
+ #install(FILES ${wine-deps} DESTINATION "${opentrack-src}/proto-wine")
+ set(winegxx-multilib "-m32")
+ if (NOT OPENTRACK_WINE_ARCH STREQUAL "")
+ set(winegxx-multilib "${OPENTRACK_WINE_ARCH}")
+ endif()
add_custom_command(
OUTPUT opentrack-wrapper-wine.exe.so
DEPENDS ${wine-deps}
- COMMAND ${SDK_WINE_PREFIX}/bin/wineg++ -g -DNOMINMAX -O2 -m32 -std=c++14 -o
+ COMMAND wineg++ -mconsole -g -DNOMINMAX -O2 ${winegxx-multilib} -std=c++17 -fPIC -o
opentrack-wrapper-wine.exe -I "${CMAKE_SOURCE_DIR}" -I "${CMAKE_BINARY_DIR}"
- ${wine-deps}
+ ${wine-deps} -Wall -Wextra -Wpedantic
${my-rt})
- add_custom_target(wine-wrapper ALL DEPENDS opentrack-wrapper-wine.exe.so)
+ add_custom_target(wine-wrapper DEPENDS opentrack-wrapper-wine.exe.so)
add_dependencies(opentrack-proto-wine wine-wrapper)
add_dependencies(wine-wrapper opentrack-compat)
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/opentrack-wrapper-wine.exe.so" DESTINATION ${opentrack-hier-pfx})
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/opentrack-wrapper-wine.exe.so" DESTINATION ${opentrack-libexec})
endif()
endif()
endif()