summaryrefslogtreecommitdiffhomepage
path: root/tracker-hatire/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tracker-hatire/CMakeLists.txt')
-rw-r--r--tracker-hatire/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/tracker-hatire/CMakeLists.txt b/tracker-hatire/CMakeLists.txt
index 39431724..01dd52b9 100644
--- a/tracker-hatire/CMakeLists.txt
+++ b/tracker-hatire/CMakeLists.txt
@@ -1,5 +1,8 @@
if(Qt5SerialPort_FOUND)
otr_module(tracker-hatire)
- target_link_libraries(opentrack-tracker-hatire ${Qt5SerialPort_LIBRARIES})
- target_include_directories(opentrack-tracker-hatire SYSTEM PUBLIC ${Qt5SerialPort_INCLUDE_DIRS})
+ target_link_libraries(${self} ${Qt5SerialPort_LIBRARIES})
+ target_include_directories(${self} SYSTEM PUBLIC ${Qt5SerialPort_INCLUDE_DIRS})
+ if (WIN32 OR APPLE)
+ otr_install_lib(Qt5::SerialPort .)
+ endif()
endif()