summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2024-02-08 08:30:01 +0100
committerStanislaw Halik <sthalik@misaki.pl>2024-02-08 08:30:01 +0100
commit577a4f6648e5cc2f145c5b9a81c2a540b9d94096 (patch)
treec0399b18eeed3d57ab36eb029cb3b27a2baddd73 /CMakeLists.txt
parent64f029f2a32ec40dc1a5eeb463d78cd7726a1909 (diff)
TO FIXUP fix splitdebug
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f81010a5..ae6ad761 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,11 @@ if(NOT GENERATOR_IS_MULTI_CONFIG)
set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "DEBUG;RELEASE;RELWITHDEBINFO")
endif()
+if(NOT MSVC)
+ set(FLOORMAT_SPLIT-DEBUG-INFO ON CACHE BOOL
+ "whether to strip out debug info from foo.exe to foo.exe.debug")
+endif()
+
if(CMAKE_INSTALL_PREFIX STREQUAL "" OR CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
set(CMAKE_INSTALL_PREFIX "${CMAKE_BINARY_DIR}/install" CACHE PATH "" FORCE)
endif()
@@ -221,7 +226,7 @@ elseif(CMAKE_COMPILER_IS_GNUCXX)
endif()
function(fm_install_executable self)
- if(NOT MSVC AND NOT APPLE)
+ if(NOT MSVC AND NOT APPLE AND FLOORMAT_SPLIT-DEBUG-INFO)
if(CMAKE_RUNTIME_OUTPUT_DIRECTORY STREQUAL "")
message(FATAL_ERROR "")
endif()