summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-12-05 07:48:36 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-12-05 07:48:51 +0100
commitbd34d6ef65fed8d28be57a41f70bf2abada00c76 (patch)
tree63d4899e781f3e5e1e10966aaf6f430e4d3b55b0 /CMakeLists.txt
parent900d775c8f4f078dc7cba8557e3991e52d2d5f89 (diff)
cmake: remove transitive deps to speed up build
Also build them out of order to make sure there are no dependencies remaining.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1f95fb6..744c7bfa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -197,13 +197,13 @@ include_directories(SYSTEM
)
#add_subdirectory(demangle)
-add_subdirectory(src)
-add_subdirectory(serialize)
-add_subdirectory(anim-crop-tool)
-add_subdirectory(draw)
add_subdirectory(main)
+add_subdirectory(draw)
+add_subdirectory(serialize)
+add_subdirectory(src)
add_subdirectory(editor)
add_subdirectory(test)
+add_subdirectory(anim-crop-tool)
install(DIRECTORY images anim scenery DESTINATION "share/floormat")