summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-11-07 06:35:29 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-11-07 06:35:29 +0100
commitfd9a69fcd6616b0bedbd1b30339b37becd21ba36 (patch)
tree542005d15c87c8ab9d30562b34fe093c7f266131 /CMakeLists.txt
parent9045f8cb38893d1bc75275e2773052f8e75af5c7 (diff)
cmake cruft
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c8fa04d..67f1741f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -144,12 +144,14 @@ include_directories(.)
include_directories(src)
get_property(_fm-sdl2-include-dirs TARGET SDL2::SDL2 PROPERTY INTERFACE_INCLUDE_DIRECTORIES)
+get_property(_fm-json-include-dirs TARGET nlohmann_json::nlohmann_json PROPERTY INTERFACE_INCLUDE_DIRECTORIES)
include_directories(SYSTEM
"${CORRADE_INCLUDE_DIR}"
"${MAGNUM_INCLUDE_DIR}"
"${MAGNUMPLUGINS_INCLUDE_DIR}"
"${MAGNUMINTEGRATION_INCLUDE_DIR}"
"${_fm-sdl2-include-dirs}"
+ "${_fm-json-include-dirs}"
)
add_subdirectory(src)