summaryrefslogtreecommitdiffhomepage
path: root/editor/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-24 12:54:15 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-24 12:54:15 +0200
commit7b61abef4662560924265357fbe8c4d50ecd389c (patch)
treed73c41ce9102a40cc5b27fac75efcb9efa789b9e /editor/CMakeLists.txt
parent700942f351d85f326bb1d6725e688920dc8de942 (diff)
a
Diffstat (limited to 'editor/CMakeLists.txt')
-rw-r--r--editor/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/editor/CMakeLists.txt b/editor/CMakeLists.txt
index aef82fec..8e96f92b 100644
--- a/editor/CMakeLists.txt
+++ b/editor/CMakeLists.txt
@@ -12,4 +12,8 @@ endif()
add_executable(${self} "${sources}" "${res}" "../loader/loader-impl.cpp")
target_link_libraries(${self} ${PROJECT_NAME}-main)
+if(FLOORMAT_PRECOMPILED-HEADERS)
+ target_precompile_headers(${self} PRIVATE precomp.hpp)
+endif()
+
install(TARGETS ${self} RUNTIME DESTINATION bin)