summaryrefslogtreecommitdiffhomepage
path: root/editor/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-04-10 08:52:32 +0200
committerStanislaw Halik <sthalik@misaki.pl>2023-04-10 10:35:00 +0200
commitfdcff54e1d845343cdfe39040aac6f7ff9b4163a (patch)
treedb8de10a96b8022f43761c74a2d58453e3380d93 /editor/CMakeLists.txt
parent8c867fac69fa9da0370000fa170cad1e22702ce5 (diff)
cmake: remove precompiled headers
They were having problems including fmtlib and robin_map.
Diffstat (limited to 'editor/CMakeLists.txt')
-rw-r--r--editor/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/editor/CMakeLists.txt b/editor/CMakeLists.txt
index f94c21e1..306c95f4 100644
--- a/editor/CMakeLists.txt
+++ b/editor/CMakeLists.txt
@@ -23,16 +23,9 @@ if(NOT SDL2_INCLUDE_DIRS)
get_target_property(SDL2_INCLUDE_DIRS SDL2::SDL2 INTERFACE_INCLUDE_DIRECTORIES)
endif()
endif()
-if(FLOORMAT_PRECOMPILED-HEADERS)
- include_directories("${SDL2_INCLUDE_DIRS}")
-endif()
set_property(SOURCE "events.cpp" APPEND PROPERTY INCLUDE_DIRECTORIES "${SDL2_INCLUDE_DIRS}")
add_executable(${self} dummy.cc)
target_link_libraries(${self} PRIVATE ${self}_o floormat-main floormat-serialize floormat-draw floormat)
-if(FLOORMAT_PRECOMPILED-HEADERS)
- target_precompile_headers(${self}_o PRIVATE precomp.hpp)
-endif()
-
install(TARGETS ${self} RUNTIME DESTINATION bin)