summaryrefslogtreecommitdiffhomepage
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-10-24 12:54:15 +0200
committerStanislaw Halik <sthalik@misaki.pl>2022-10-24 12:54:15 +0200
commit7b61abef4662560924265357fbe8c4d50ecd389c (patch)
treed73c41ce9102a40cc5b27fac75efcb9efa789b9e /main/CMakeLists.txt
parent700942f351d85f326bb1d6725e688920dc8de942 (diff)
a
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index 77538920..a2d71a61 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -1,11 +1,12 @@
+set(self ${PROJECT_NAME}-main)
file(GLOB sources "*.cpp" CONFIGURE_ARGS)
link_libraries(${PROJECT_NAME})
link_libraries(Magnum::Sdl2Application Corrade::Containers Magnum::GL Magnum::Trade)
link_libraries(MagnumIntegration::ImGui)
-add_library(${PROJECT_NAME}-main STATIC "${sources}")
+add_library(${self} STATIC "${sources}")
if(FLOORMAT_PRECOMPILED-HEADERS)
- target_precompile_headers(${PROJECT_NAME}-main PRIVATE precomp.hpp)
+ target_precompile_headers(${self} PRIVATE precomp.hpp)
endif()