summaryrefslogtreecommitdiffhomepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2022-11-10 17:01:30 +0100
committerStanislaw Halik <sthalik@misaki.pl>2022-11-10 22:17:43 +0100
commit0e23ba9e5a565e34fee0f024e29ce162f420ec22 (patch)
treeeeaf0ec198ba8849117c9c21675a651e8c93acad /test/CMakeLists.txt
parent67f0ff04d0fb71255d35bf7f31a684d7a2120c2a (diff)
add github action
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0ef13ac6..0f5ca85d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -4,7 +4,15 @@ file(GLOB sources "*.cpp" CONFIGURE_ARGS)
file(MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/test")
link_libraries(${PROJECT_NAME})
-link_libraries(Magnum::WindowlessWglApplication Magnum::Trade)
+link_libraries(Magnum::Trade)
+
+if(APPLE)
+ link_libraries(Magnum::WindowlessCglApplication)
+elseif(WIN32)
+ link_libraries(Magnum::WindowlessWglApplication)
+else()
+ link_libraries(Magnum::WindowlessGlxApplication)
+endif()
add_executable(${self} "${sources}" "../loader/loader-impl.cpp")
install(TARGETS ${self} RUNTIME DESTINATION bin)