summaryrefslogtreecommitdiffhomepage
path: root/editor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'editor/CMakeLists.txt')
-rw-r--r--editor/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/editor/CMakeLists.txt b/editor/CMakeLists.txt
index 3e19248a..81afadd0 100644
--- a/editor/CMakeLists.txt
+++ b/editor/CMakeLists.txt
@@ -3,11 +3,7 @@ set(self floormat-editor)
file(GLOB sources "*.cpp" "tests/*.cpp" CONFIGURE_ARGS)
corrade_add_resource(res "../resources.conf")
-if(MSVC)
- set_property(SOURCE "${res}" APPEND PROPERTY COMPILE_OPTIONS "-W0")
-else()
- set_property(SOURCE "${res}" APPEND PROPERTY COMPILE_OPTIONS "-w")
-endif()
+set_property(SOURCE "${res}" APPEND PROPERTY COMPILE_OPTIONS "-w") # no warnings
add_library(${self}_o OBJECT "${res}" "${sources}")
target_link_libraries(${self}_o PUBLIC MagnumIntegration::ImGui fmt::fmt nlohmann_json::nlohmann_json tsl::robin_map)